Announcement

Collapse
No announcement yet.

Issues with SC injector

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Right. Check the 4 screws andmake sure they are tight.
    sigpic


    1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

    Comment


    • Ok, I'll check that when I have time to remove the radiator and all that.

      What should be the base idle AFR?
      I just put it back together after setting the proper timing.
      It's currently sitting at 14.7-15 after warming up for 5 minutes

      Comment


      • Right. Check the 4 screws andmake sure they are tight.
        1r.5 to 15 is good
        sigpic


        1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

        Comment


        • I did some full throttle test at 2.5-3.5K RPMs and the AFR would be around 13 and keeps climbing as RPMs go over 5k which I imagine is normal.

          Remind me what I should be seeing under load in terms of AFR?

          Comment


          • By climbing, I assume you mean richer. Should be at least 12 by 4ooo rpm.
            sigpic


            1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

            Comment


            • No, the opposite, as it goes up to 4K rpm it's going up in AFR, getting leaner

              Comment


              • Possibly the extra injector is not functioning? There should be a red wire and a white with red stripe going from the ECool card to the injector. With the engine running, if you ground the white/red wire, the afr should go pig rich.
                sigpic


                1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

                Comment


                • I disconnected the white/red and there was no effect when doing load testing 3k rpm+

                  Grounding the wire does flood the engine.
                  do you think it's a connectivity issue ?
                  How can I test the outgoing signal of the card ?‚Äč

                  Comment


                  • A voltmeter might see the signal. It will be AC as it is just an on/off 12V sigmnal on the wghite/red wire that is duty cycle controlled. But you will have to be under load so you will have to be driving. Get some long leads and have a passenger watch the voltmater tied from red/white to ground.
                    sigpic


                    1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

                    Comment


                    • I was able to connect my voltmeter and that luckily has a MAX feature so I was able to conduct the test without a passenger. The signal is recorded, what is the max voltage? I was able to read max of 20V when it was wide-open throttle above 3K RPMs, maybe the spike was just captured by the voltmeter but could that be a problem?

                      Comment


                      • It is a pulsed 12v signal
                        sigpic


                        1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

                        Comment


                        • Weird that the signal would pick up something higher. Could the SC be making too much boost? I was seeing 8.4 psi on my sensor at some points

                          Comment


                          • Boost has nothing to do with the voltage at the injector. 100% on would read 12V. 50% duty cycle should read around 6V. Etc>
                            sigpic


                            1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

                            Comment

                            Working...
                            X