Announcement

Collapse
No announcement yet.

Issues with SC injector

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Yes it is all original, and it doesn't come out when pulled
    I put my arm rest back on and maybe it might have twisted something but it is odd that it won't seal, it takes a lot of pressure to push it in and have it not leak. The outer plastic ring, the one where the hose goes into, is a bit loose, is that potentially the problem?

    Comment


    • #62
      Send me an address and I will send another fitting.
      sigpic


      1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

      Comment


      • #63
        Looks like I cannot send you private messages so I just emailed you my address to your knacktoys address.

        Thanks again.

        Comment


        • #64
          Did not receive an email.
          sigpic


          1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

          Comment


          • #65
            Is [email protected] the wrong email?
            the subject line was 'Black tubing fitting from FFS forum' from [email protected]

            Comment


            • #66
              correct email. Never got it. Send again
              sigpic


              1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

              Comment


              • #67
                Did you receive my second attempt? It had the same subject line

                Comment


                • #68
                  Nope. Check your "outbox".
                  sigpic


                  1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

                  Comment


                  • #69
                    Outbox is clear, all emails appear in the sent folder.
                    I just replied to two different old email threads and also sent an email from a different account, all to [email protected]

                    Hopefully that gets through.

                    Comment


                    • #70
                      it is on its way to you.
                      sigpic


                      1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

                      Comment


                      • #71
                        Thanks, hopefully that fixes something but given that prior to that leak the wideband has never at the proper AFR, what other things should I be testing in the mean time?

                        Timing? Fuel pressure? Bypass valves? Can you think of anything that might also be contributing to the lean issue? Even when I hooked up the new sensor and had everything running, it was never at 12 AFR.

                        Comment


                        • #72
                          Front O2 sensor. It is most likely culprit if Wideband is good. At idle and cruise, AFR should be around 14.5. At WOT above 4000 rpm, AFR should be 11-12.
                          sigpic


                          1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

                          Comment


                          • #73
                            Anything stick out from these readings ?
                            Attached Files

                            Comment


                            • #74
                              One question, is the MAF used for the kit different from the stock one? Id like to bench test it. Do you have specs?

                              Comment


                              • #75
                                MAF is your stock MAF. Unplug front O2. Take lpositive lead off of battery. Hold it on ground for 10 seconds or so. Put it back on. DO NOT RECONNECT O2 YET. Start engine and let it warm up. After it is all warmed up, check AFR at idle. Go for a ride (no boost). Check AFR at cruise on flat/level road 45-50 mph in 5th gear. Should be high 13s to low 15s. Closer to 14.5 the better. This is a good way to test MAF.

                                Tom

                                you will likely get a CEL for disconnected O2. Ignore it. After test, don't forget to plug it back in.
                                sigpic


                                1990 with FFS Coldside. At least 260 WHP NON-INTERCOOLED

                                Comment

                                Working...
                                X